aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Hinton <hintonda@gmail.com>2017-12-12 19:47:40 +0000
committerDon Hinton <hintonda@gmail.com>2017-12-12 19:47:40 +0000
commit65e2ef95afb1d7b50394b16d7aa306c043f945b9 (patch)
treed3084ca69c4733885bdae142f4b8b5131ec85764 /test/CMakeLists.txt
parentc7f86237939adefbfc16599d4b932ac352257958 (diff)
[cmake] Follow-up to rL320494.
EXISTS requires full paths. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@320519 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 327226fe60..4b0e94b666 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -134,9 +134,9 @@ set_target_properties(clang-test PROPERTIES FOLDER "Clang tests")
# FIXME: This logic can be removed once all buildbots have moved
# debuginfo-test from clang/test to llvm/projects or monorepo.
-if(EXISTS debuginfo-tests)
+if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/debuginfo-tests)
message(WARNING "Including debuginfo-tests in clang/test is deprecated. Move to llvm/projects or use monorepo.")
- if(EXISTS debuginfo-tests/CMakeLists.txt)
+ if(EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/debuginfo-tests/CMakeLists.txt)
add_subdirectory(debuginfo-tests)
endif()
endif()