aboutsummaryrefslogtreecommitdiff
path: root/lib/Headers/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Devlieghere <jonas@devlieghere.com>2019-05-07 21:08:15 +0000
committerJonas Devlieghere <jonas@devlieghere.com>2019-05-07 21:08:15 +0000
commite163cbcd8fe0e9b1581e1434ec734665b2f2fc85 (patch)
tree68f9573e4a27faf814a5a460ae936a0102375986 /lib/Headers/CMakeLists.txt
parent71cb0968116c5cf783aebae06b39d6d31f085c2e (diff)
Revert "[OpenMP][Clang] Support for target math functions"
This commit appears to be breaking stage-2 builds on GreenDragon. The OpenMP wrappers for cmath and math.h are copied into the root of the resource directory and cause a cyclic dependency in module 'Darwin': Darwin -> std -> Darwin. This blows up when CMake is testing for modules support and breaks all stage 2 module builds, including the ThinLTO bot and all LLDB bots. CMake Error at cmake/modules/HandleLLVMOptions.cmake:497 (message): LLVM_ENABLE_MODULES is not supported by this compiler git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@360192 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Headers/CMakeLists.txt')
-rw-r--r--lib/Headers/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/lib/Headers/CMakeLists.txt b/lib/Headers/CMakeLists.txt
index 803e65a2e1..bfcade4584 100644
--- a/lib/Headers/CMakeLists.txt
+++ b/lib/Headers/CMakeLists.txt
@@ -33,9 +33,6 @@ set(files
avxintrin.h
bmi2intrin.h
bmiintrin.h
- openmp_wrappers/math.h
- openmp_wrappers/cmath
- openmp_wrappers/__clang_openmp_math.h
__clang_cuda_builtin_vars.h
__clang_cuda_cmath.h
__clang_cuda_complex_builtins.h