aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 663cacf6f..5fbe3681f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,11 +6,13 @@ if PLATFORM_IS_LINUX_GENERIC
PLATFORM_DIR = platform/linux-generic
PLATFORM_DUMPCONF_DIR = platform/linux-generic/dumpconfig
PLATFORM_TEST_DIR = platform/linux-generic/test
+PLATFORM_EXAMPLE_DIR = platform/linux-generic/example
endif
if PLATFORM_IS_LINUX_DPDK
PLATFORM_DIR = platform/linux-dpdk
PLATFORM_DUMPCONF_DIR = platform/linux-dpdk/dumpconfig
PLATFORM_TEST_DIR = platform/linux-dpdk/test
+PLATFORM_EXAMPLE_DIR = platform/linux-dpdk/example
endif
SUBDIRS = \
@@ -30,6 +32,7 @@ endif
if WITH_EXAMPLES
SUBDIRS += example
+SUBDIRS += $(PLATFORM_EXAMPLE_DIR)
endif
if WITH_TESTS