aboutsummaryrefslogtreecommitdiff
path: root/platform/linux-generic/Makefile.am
diff options
context:
space:
mode:
authorPetri Savolainen <petri.savolainen@nokia.com>2022-08-31 16:38:27 +0300
committerMatias Elo <matias.elo@nokia.com>2022-09-07 15:04:41 +0300
commitb1930c5262cacc83a18acaf6df249fb4e519c244 (patch)
tree1f273f7d46a9fdcff160bb8e4de19ec080f07e38 /platform/linux-generic/Makefile.am
parente10feab32a9950f90e276662bb244c8e81d42553 (diff)
linux-gen: print: add _odp_snprint()
This new function can be used in place of snprintf() to format strings for output. It is easier to use than snprintf() as it returns always the number of characters printed. Signed-off-by: Petri Savolainen <petri.savolainen@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'platform/linux-generic/Makefile.am')
-rw-r--r--platform/linux-generic/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/platform/linux-generic/Makefile.am b/platform/linux-generic/Makefile.am
index 56a37544c..708526558 100644
--- a/platform/linux-generic/Makefile.am
+++ b/platform/linux-generic/Makefile.am
@@ -135,6 +135,7 @@ noinst_HEADERS = \
include/odp_packet_internal.h \
include/odp_packet_io_internal.h \
include/odp_parse_internal.h \
+ include/odp_print_internal.h \
include/odp_socket_common.h \
include/odp_packet_io_stats_common.h \
include/odp_packet_io_stats.h \
@@ -213,6 +214,7 @@ __LIB__libodp_linux_la_SOURCES = \
odp_packet_io.c \
odp_parse.c \
odp_pkt_queue.c \
+ odp_print.c \
odp_pool.c \
odp_pool_mem_src_ops.c \
odp_queue_basic.c \