summaryrefslogtreecommitdiff
path: root/debian/rules.real
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 545e4d947..4793fb36f 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -87,6 +87,8 @@ $(BUILD_DIR)/linux-source-$(UPSTREAMVERSION).tar.xz: $(STAMPS_DIR)/source
rm -rf '$@' '$(DIR)'
$(call copy_source,$(DIR))
chmod -R u+rw,go=rX '$(DIR)'
+ find '$(DIR)' -depth -newermt '$(SOURCE_DATE)' -print0 | \
+ xargs -0r touch --no-dereference --date='$(SOURCE_DATE)'
cd '$(BUILD_DIR)'; tar -caf 'linux-source-$(UPSTREAMVERSION).tar.xz' 'linux-source-$(UPSTREAMVERSION)'
rm -rf '$(DIR)'
@@ -202,7 +204,7 @@ install-doc: $(STAMPS_DIR)/build-doc
cd $(DIR)/Documentation/DocBook; \
find * -name '*.html' -print | \
cpio -pd --preserve-modification-time '$(CURDIR)/$(OUT_DIR)/html'
- gzip -9qfr $(OUT_DIR)/Documentation
+ gzip -9nqfr $(OUT_DIR)/Documentation
+$(MAKE_SELF) install-base
install-manual: PACKAGE_NAME = linux-manual-$(VERSION)