summaryrefslogtreecommitdiff
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2015-05-12 19:11:55 +0000
committerBen Hutchings <benh@debian.org>2015-05-12 19:11:55 +0000
commit9a70d28e7dba3016a6d5eeed6508a1d8c178701b (patch)
tree3c1dbb7126b44cc7074b02f27243f3e7e3e4bb33 /debian/rules.real
parent35112ab3eb0303179bd916b4ea2e897da56ec63c (diff)
Apply more timestamp fixes from Jérémy Bobbio in #769844
svn path=/dists/trunk/linux/; revision=22649
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 545e4d947..4793fb36f 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -87,6 +87,8 @@ $(BUILD_DIR)/linux-source-$(UPSTREAMVERSION).tar.xz: $(STAMPS_DIR)/source
rm -rf '$@' '$(DIR)'
$(call copy_source,$(DIR))
chmod -R u+rw,go=rX '$(DIR)'
+ find '$(DIR)' -depth -newermt '$(SOURCE_DATE)' -print0 | \
+ xargs -0r touch --no-dereference --date='$(SOURCE_DATE)'
cd '$(BUILD_DIR)'; tar -caf 'linux-source-$(UPSTREAMVERSION).tar.xz' 'linux-source-$(UPSTREAMVERSION)'
rm -rf '$(DIR)'
@@ -202,7 +204,7 @@ install-doc: $(STAMPS_DIR)/build-doc
cd $(DIR)/Documentation/DocBook; \
find * -name '*.html' -print | \
cpio -pd --preserve-modification-time '$(CURDIR)/$(OUT_DIR)/html'
- gzip -9qfr $(OUT_DIR)/Documentation
+ gzip -9nqfr $(OUT_DIR)/Documentation
+$(MAKE_SELF) install-base
install-manual: PACKAGE_NAME = linux-manual-$(VERSION)