aboutsummaryrefslogtreecommitdiff
path: root/ui/meson.build
diff options
context:
space:
mode:
authorMark Cave-Ayland <mark.cave-ayland@ilande.co.uk>2020-08-25 23:23:10 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-27 18:52:30 +0200
commitec14f888b875943cceefda214eeed27c6c6440a6 (patch)
treec4f0fba2881f85e15baceaa3654bd402db8b30d3 /ui/meson.build
parent1917ec6d564d3fae404adedcbb6e8a724fba8894 (diff)
meson: don't require CONFIG_VTE for the GTK UI
Prevously CONFIG_VTE was not required to build QEMU with GTK UI support as not all platforms have VTE available (in particular Windows). Remove this requirement from the meson build system to enable QEMU to be built with GTK UI support for Windows once again. Signed-off-by: Mark Cave-Ayland <mark.cave-ayland@ilande.co.uk> Reviewed-by: Gerd Hoffmann <kraxel@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'ui/meson.build')
-rw-r--r--ui/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/ui/meson.build b/ui/meson.build
index 393c9bcb53..962e776569 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -44,7 +44,7 @@ if config_host.has_key('CONFIG_CURSES')
ui_modules += {'curses' : curses_ss}
endif
-if config_host.has_key('CONFIG_GTK') and config_host.has_key('CONFIG_VTE')
+if config_host.has_key('CONFIG_GTK')
softmmu_ss.add(when: 'CONFIG_WIN32', if_true: files('win32-kbd-hook.c'))
gtk_ss = ss.source_set()