aboutsummaryrefslogtreecommitdiff
path: root/meta-optee
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2016-11-23 09:55:42 +0100
committerFathi Boudra <fathi.boudra@linaro.org>2016-11-23 08:58:01 +0000
commitaf872108bab21a46b85f7158c201223b504af6e7 (patch)
tree9927e47231b7bb339a6573d78c6fa7e8bd3896ff /meta-optee
parent5132a5e73f599d56973386a328d1ba56962d2b27 (diff)
optee-client: respect OE's ${libdir}
This fixes multilib builds. Change-Id: I1d2bf66cac3db82a6cdf5344b0dce339e18897ce Signed-off-by: Koen Kooi <koen.kooi@linaro.org>
Diffstat (limited to 'meta-optee')
-rw-r--r--meta-optee/recipes-security/optee/optee-client.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-optee/recipes-security/optee/optee-client.bb b/meta-optee/recipes-security/optee/optee-client.bb
index c25954e6..411635e9 100644
--- a/meta-optee/recipes-security/optee/optee-client.bb
+++ b/meta-optee/recipes-security/optee/optee-client.bb
@@ -18,14 +18,19 @@ SYSTEMD_SERVICE_${PN} = "tee-supplicant.service"
do_compile() {
install -d ${D}${prefix}
- oe_runmake EXPORT_DIR=${D}${prefix}/
+ oe_runmake EXPORT_DIR=${D}${prefix}
}
do_install() {
- install -d ${D}${prefix}
+ install -d ${D}${libdir}
+ install -d ${D}${bindir}
+
+ # fix up hardcoded /lib paths
+ sed -i -e 's:EXPORT_DIR}/lib:EXPORT_DIR}${base_libdir}:g' ${S}/Makefile
+
oe_runmake install EXPORT_DIR=${D}${prefix}
- ( cd ${D}${prefix}/lib
+ ( cd ${D}${libdir}
rm libteec.so libteec.so.1
ln -s libteec.so.1.0 libteec.so.1
ln -s libteec.so.1.0 libteec.so