aboutsummaryrefslogtreecommitdiff
path: root/meta-optee/recipes-security
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2016-06-27 17:49:13 +0300
committerFathi Boudra <fathi.boudra@linaro.org>2016-06-27 17:49:13 +0300
commit831c8f081db5721817f487c619219ec1a7997ae9 (patch)
tree06c15bd294c1b498040bb9f2e591fc4336d2076e /meta-optee/recipes-security
parentc38ccd7280b8d0dc347f75e854fdccff21ad3861 (diff)
optee-os: create optee directory only if it is armv7
optee directory under $DEPLOYDIR has content only if the architecture is ARMv7. Otherwise, it's empty. Create the directory only when we need to fill it. Change-Id: Ie150007913658cb36038fc916743b0b0ca6b859e Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-optee/recipes-security')
-rw-r--r--meta-optee/recipes-security/optee/optee-os_git.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-optee/recipes-security/optee/optee-os_git.bb b/meta-optee/recipes-security/optee/optee-os_git.bb
index daf7428e..2828476c 100644
--- a/meta-optee/recipes-security/optee/optee-os_git.bb
+++ b/meta-optee/recipes-security/optee/optee-os_git.bb
@@ -58,9 +58,8 @@ do_deploy() {
long_srvrev=${SRCREV}
short_srvrev=$(echo $long_srvrev | awk '{ string=substr($0, 1, 8); print string; }' )
OPTEE_CORE_SUFFIX="${MACHINE}-$short_srvrev"
- install -d ${DEPLOYDIR}/optee
- if [ "${is_armv7}" = "1" ];
- then
+ if [ "${is_armv7}" = "1" ]; then
+ install -d ${DEPLOYDIR}/optee
for f in ${D}/lib/firmware/*; do
filename=$(basename "$f")
extension="${filename##*.}"