aboutsummaryrefslogtreecommitdiff
path: root/newlib/libc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/configure.in')
-rw-r--r--newlib/libc/configure.in105
1 files changed, 0 insertions, 105 deletions
diff --git a/newlib/libc/configure.in b/newlib/libc/configure.in
deleted file mode 100644
index eeb5286bd..000000000
--- a/newlib/libc/configure.in
+++ /dev/null
@@ -1,105 +0,0 @@
-dnl This is the newlib/libc configure.in file.
-dnl Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.5)
-AC_INIT(sys.tex)
-
-dnl Can't be done in NEWLIB_CONFIGURE because that confuses automake.
-AC_CONFIG_AUX_DIR(../..)
-
-NEWLIB_CONFIGURE(..)
-
-dnl We have to enable libtool after NEWLIB_CONFIGURE because if we try and
-dnl add it into NEWLIB_CONFIGURE, executable tests are made before the first
-dnl line of the macro which fail because appropriate LDFLAGS are not set.
-
-if test "${use_libtool}" = "yes"; then
-AC_LIBTOOL_WIN32_DLL
-AM_PROG_LIBTOOL
-fi
-
-AC_CONFIG_SUBDIRS(machine sys)
-
-CRT0=
-if test -n "${sys_dir}"; then
- CRT0=crt0.o
-fi
-AC_SUBST(CRT0)
-
-dnl For each directory which we may or may not want, we define a name
-dnl for the library and an automake conditional for whether we should
-dnl build the library.
-
-LIBC_POSIX_LIB=
-if test -n "${posix_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_POSIX_LIB=${posix_dir}/lib${posix_dir}.${aext}
- else
- LIBC_POSIX_LIB=${posix_dir}/lib.${aext}
- fi
-fi
-AC_SUBST(LIBC_POSIX_LIB)
-AM_CONDITIONAL(HAVE_POSIX_DIR, test x${posix_dir} != x)
-
-LIBC_SIGNAL_LIB=
-LIBC_SIGNAL_DEF=
-if test -n "${signal_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_SIGNAL_LIB=${signal_dir}/lib${signal_dir}.${aext}
- else
- LIBC_SIGNAL_LIB=${signal_dir}/lib.${aext}
- fi
- LIBC_SIGNAL_DEF=${signal_dir}/stmp-def
-fi
-AC_SUBST(LIBC_SIGNAL_LIB)
-AC_SUBST(LIBC_SIGNAL_DEF)
-AM_CONDITIONAL(HAVE_SIGNAL_DIR, test x${signal_dir} != x)
-
-LIBC_SYSCALL_LIB=
-if test -n "${syscall_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_SYSCALL_LIB=${syscall_dir}/lib${syscall_dir}.${aext}
- else
- LIBC_SYSCALL_LIB=${syscall_dir}/lib.${aext}
- fi
-fi
-AC_SUBST(LIBC_SYSCALL_LIB)
-AM_CONDITIONAL(HAVE_SYSCALL_DIR, test x${syscall_dir} != x)
-
-LIBC_UNIX_LIB=
-if test -n "${unix_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_UNIX_LIB=${unix_dir}/lib${unix_dir}.${aext}
- else
- LIBC_UNIX_LIB=${unix_dir}/lib.${aext}
- fi
-fi
-AC_SUBST(LIBC_UNIX_LIB)
-AM_CONDITIONAL(HAVE_UNIX_DIR, test x${unix_dir} != x)
-
-dnl We always recur into sys and machine, and let them decide what to
-dnl do. However, we do need to know whether they will produce a library.
-
-LIBC_SYS_LIB=
-if test -n "${sys_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_SYS_LIB=sys/${sys_dir}/lib${sys_dir}.${aext}
- else
- LIBC_SYS_LIB=sys/lib.${aext}
- fi
-fi
-AC_SUBST(LIBC_SYS_LIB)
-AC_SUBST(sys_dir)
-
-LIBC_MACHINE_LIB=
-if test -n "${machine_dir}"; then
- if test "${use_libtool}" = "yes"; then
- LIBC_MACHINE_LIB=machine/${machine_dir}/lib${machine_dir}.${aext}
- else
- LIBC_MACHINE_LIB=machine/lib.${aext}
- fi
-fi
-AC_SUBST(LIBC_MACHINE_LIB)
-AC_SUBST(machine_dir)
-
-AC_OUTPUT(Makefile ctype/Makefile errno/Makefile locale/Makefile misc/Makefile reent/Makefile stdio/Makefile stdlib/Makefile string/Makefile time/Makefile posix/Makefile signal/Makefile syscalls/Makefile unix/Makefile)