aboutsummaryrefslogtreecommitdiff
path: root/External/SPEC/CFP2017speed/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Kruse <llvm@meinersbur.de>2017-08-21 22:33:49 +0000
committerMichael Kruse <llvm@meinersbur.de>2017-08-21 22:33:49 +0000
commitd6619a21110d71b9c055dc52199c409ca4cdbdce (patch)
tree45dfaced54b25b006a9d49ec091194603a5b15b9 /External/SPEC/CFP2017speed/CMakeLists.txt
parent2283f261335afd7fa0b5995f0cb75f099ea5f110 (diff)
SPEC2017: Add initial CMakeLists.
Add CMakeLists.txt files for SPEC CPU 2017. All C/C++-only benchmarks are included, grouped by benchmark suite (SPECrate 2017 Integer, SPECspeed 2017 Integer, SPECrate 2017 Floating Point, SPECspeed 2017 Floating Point). SPEC's changes to some of the benchmarks (at least perlbench) require them to be invoked with a relative path (because for finding its working directory, it prepends a path to basename(argv[0])). When the executable is referred to by a relative path, litsupport needs to take cd commands before into account, otherwise it won't find the executable. Differential Revision: https://reviews.llvm.org/D36717 git-svn-id: https://llvm.org/svn/llvm-project/test-suite/trunk@311395 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'External/SPEC/CFP2017speed/CMakeLists.txt')
-rw-r--r--External/SPEC/CFP2017speed/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/External/SPEC/CFP2017speed/CMakeLists.txt b/External/SPEC/CFP2017speed/CMakeLists.txt
new file mode 100644
index 00000000..edb54654
--- /dev/null
+++ b/External/SPEC/CFP2017speed/CMakeLists.txt
@@ -0,0 +1,12 @@
+#add_subdirectory(603.bwaves_s) # Fortran
+#add_subdirectory(607.cactuBSSN_s) # C++, C, Fortran
+add_subdirectory(619.lbm_s) # C
+#add_subdirectory(621.wrf_s) # Fortran, C
+#add_subdirectory(627.cam4_s) # Fortran, C
+#add_subdirectory(628.pop2_s) # Fortran, C
+add_subdirectory(638.imagick_s) # C
+add_subdirectory(644.nab_s) # C
+#add_subdirectory(649.fotonik3d_s) # Fortran
+#add_subdirectory(654.roms_s) # Fortran
+
+add_subdirectory(996.specrand_fs) # C