aboutsummaryrefslogtreecommitdiff
path: root/final/libomptarget/plugins/x86_64/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Stellard <tstellar@redhat.com>2018-12-15 04:32:11 +0000
committerTom Stellard <tstellar@redhat.com>2018-12-15 04:32:11 +0000
commit17721c5ed149d81546e092560ca2ba28331f7270 (patch)
tree07778fe8f0038268045ce4b1050cd53bbedbc838 /final/libomptarget/plugins/x86_64/CMakeLists.txt
parent9a6752f4a72f56ba2a27195e34043eebe82b5155 (diff)
Creating release candidate final from release_701 branchsvn-tags/RELEASE_701
git-svn-id: https://llvm.org/svn/llvm-project/openmp/tags/RELEASE_701@349248 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'final/libomptarget/plugins/x86_64/CMakeLists.txt')
-rw-r--r--final/libomptarget/plugins/x86_64/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/final/libomptarget/plugins/x86_64/CMakeLists.txt b/final/libomptarget/plugins/x86_64/CMakeLists.txt
new file mode 100644
index 0000000..bdd5bba
--- /dev/null
+++ b/final/libomptarget/plugins/x86_64/CMakeLists.txt
@@ -0,0 +1,18 @@
+##===----------------------------------------------------------------------===##
+#
+# The LLVM Compiler Infrastructure
+#
+# This file is dual licensed under the MIT and the University of Illinois Open
+# Source Licenses. See LICENSE.txt for details.
+#
+##===----------------------------------------------------------------------===##
+#
+# Build a plugin for a x86_64 machine if available.
+#
+##===----------------------------------------------------------------------===##
+
+if(CMAKE_SYSTEM_NAME MATCHES "Linux")
+ build_generic_elf64("x86_64" "x86_64" "x86_64" "x86_64-pc-linux-gnu" "62")
+else()
+ libomptarget_say("Not building x86_64 offloading plugin: machine not found in the system.")
+endif() \ No newline at end of file