summaryrefslogtreecommitdiff
path: root/tests/Simple_Texture2D/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2014-10-05 23:02:12 -0500
committerTom Gall <tom.gall@linaro.org>2014-10-05 23:02:12 -0500
commitffbf61c267a162c3e5d41c9ff310e2c8dae1c3bd (patch)
treeb966b6d1b2c0a6bcb8787e234defcd47ac2a1f0b /tests/Simple_Texture2D/CMakeLists.txt
Initial commit
This is the reference implementation with the miniEGL code stripped out Tests are simplistic at this point. Windowing uses traditional egl (mesa test) but should work with mali egl too.
Diffstat (limited to 'tests/Simple_Texture2D/CMakeLists.txt')
-rw-r--r--tests/Simple_Texture2D/CMakeLists.txt39
1 files changed, 39 insertions, 0 deletions
diff --git a/tests/Simple_Texture2D/CMakeLists.txt b/tests/Simple_Texture2D/CMakeLists.txt
new file mode 100644
index 0000000..c8b7468
--- /dev/null
+++ b/tests/Simple_Texture2D/CMakeLists.txt
@@ -0,0 +1,39 @@
+cmake_minimum_required(VERSION 2.8)
+
+project (SimpleTexture)
+
+set(EXECUTABLE_NAME ${PROJECT_NAME})
+
+# Linux on ARM
+#if(MALI_BUILD)
+#set(DUMMY_MALI_LIBRARIES MiniEGL EGL GLESv2 X11 pthread m gles2-bc OpenVG OpenVGU )
+#set(DUMMY_MALI_LIBRARIES GLESv2 MiniEGL gles2-bc EGL mali OpenVG OpenVGU X11 pthread m )
+#else()
+# set(DUMMY_MALI_LIBRARIES MiniEGL OpenVG OpenVGU)
+#endif()
+#set(DUMMY_MALI_LIBRARIES EGL )
+set(DEFAULT_LIB_PATH "/usr/local/lib")
+#set(MALI_LIB_PATH "/opt/mali_r4p0_02rel0/fbdev/")
+#set(MALI_LIB_PATH "/usr/lib/mali")
+
+
+set(DUMMY_MALI_LIBRARIES EGL GLESv2 X11 pthread m OpenVG )
+
+INCLUDE_DIRECTORIES("/usr/local/include")
+INCLUDE_DIRECTORIES("../../include")
+
+set(CMAKE_C_FLAGS "-g -mcpu=cortex-a15 -mfpu=neon-vfpv4 -ftree-vectorize -funsafe-math-optimizations" CACHE STRING "" FORCE)
+
+#add_subdirectory(arm)
+LINK_DIRECTORIES(${DEFAULT_LIB_PATH})
+LINK_DIRECTORIES(${MALI_LIB_PATH})
+
+set(ALL_LIBRARIES ${DUMMY_MALI_LIBRARIES})
+
+
+set(SimpleTexture_TESTS_SOURCE
+ main.c
+ )
+
+add_executable(${EXECUTABLE_NAME} ${SimpleTexture_TESTS_SOURCE})
+target_link_libraries(${EXECUTABLE_NAME} ${ALL_LIBRARIES})