aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index d3b97241..521fbf99 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -4,8 +4,8 @@ DESCRIPTION = "Target-side daemon gathering data for ARM Streamline Performance
LICENSE = "GPL-2"
LIC_FILES_CHKSUM = "file://driver/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-SRCREV = "f0ddf6b40e42579f2275974620399fb3406d0c18"
-PV = "5.21.1+git${SRCPV}"
+SRCREV = "7ca6004c0b05138c49b9b21e0045487f55a60ab6"
+PV = "5.22+git${SRCPV}"
SRC_URI = "git://git.linaro.org/arm/ds5/gator.git;protocol=http;branch=linaro \
file://gator.init"
@@ -14,13 +14,18 @@ S = "${WORKDIR}/git"
inherit update-rc.d
-EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
+# Since this is c++ code we need to both compile and link with CXX
+#| PerfSource.o: In function `PerfSource::~PerfSource()':
+#| /usr/src/debug/gator/5.22+gitAUTOINC+7ca6004c0b-r0/git/daemon/PerfSource.cpp:128: undefined reference to `operator delete(void*, unsigned long)'
+CC = "${CXX}"
+
+EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -D_DEFAULT_SOURCE -DETCDIR=\"${sysconfdir}\"' \
'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti'"
do_compile() {
# The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.
- cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
+ cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
oe_runmake -C daemon CC='${CC}' CXX='${CXX}'
}