aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-linaro/images
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2015-03-05 10:57:13 +0200
committerFathi Boudra <fathi.boudra@linaro.org>2015-03-05 10:57:13 +0200
commit46cc2c679b565388c5b1038ba23424dca5a6c7c1 (patch)
treed92572cdfc7d9a542e4bde66fce73437e89021a3 /meta-linaro/recipes-linaro/images
parent886535072a3af1c1d00df38e0c0ffbfde98742aa (diff)
linaro-image-lng: fix autoserial login and hostname
* inittab strings have changed, fixed the sed command * due to some changes in base-files, hostname was the default machine name * add comments to explain why we use the fixup instead of OE facilities Change-Id: I14dde6d3debe7bb6fe8a9e3ed47c58ba28c30fbf Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
Diffstat (limited to 'meta-linaro/recipes-linaro/images')
-rw-r--r--meta-linaro/recipes-linaro/images/linaro-image-lng.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/meta-linaro/recipes-linaro/images/linaro-image-lng.bb b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
index ca010f3a..65fa0fbf 100644
--- a/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
+++ b/meta-linaro/recipes-linaro/images/linaro-image-lng.bb
@@ -56,14 +56,16 @@ FEATURE_PACKAGES_autoserial = "auto-serial-console"
IMAGE_PREPROCESS_COMMAND_qemux86 += "qemux86_fixup;"
qemux86_fixup() {
- sed -i '/getty 115200 ttyS0/d' ${IMAGE_ROOTFS}/etc/inittab
+ # Since we use autoserial, remove serial consoles
+ # See sysvinit-inittab recipe
+ sed -i '/2345:respawn:\/sbin\/getty/d' ${IMAGE_ROOTFS}/etc/inittab
+ # Add a default network interface
echo "auto eth0" >> ${IMAGE_ROOTFS}/etc/network/interfaces
echo "iface eth0 inet dhcp" >> ${IMAGE_ROOTFS}/etc/network/interfaces
-}
-
-IMAGE_PREPROCESS_COMMAND += "do_mangle_hostname;"
-do_mangle_hostname() {
- echo 'linaro' > ${IMAGE_ROOTFS}${sysconfdir}/hostname
+ # The hostname can be changed by using
+ # hostname_pn-base-files = "linaro"
+ # See base-files recipe
+ echo "linaro" > ${IMAGE_ROOTFS}${sysconfdir}/hostname
}