aboutsummaryrefslogtreecommitdiff
path: root/test/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/common/Makefile.am')
-rw-r--r--test/common/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/common/Makefile.am b/test/common/Makefile.am
new file mode 100644
index 000000000..72658df73
--- /dev/null
+++ b/test/common/Makefile.am
@@ -0,0 +1,28 @@
+include $(top_srcdir)/test/Makefile.inc
+
+if cunit_support
+
+noinst_LTLIBRARIES = \
+ libcunit_common.la \
+ libcpumask_common.la \
+ libpacket_common.la \
+ libthrmask_common.la
+
+libcunit_common_la_SOURCES = odp_cunit_common.c odp_cunit_common.h
+libcunit_common_la_LIBADD = $(CUNIT_LIBS)
+
+libcpumask_common_la_SOURCES = mask_common.c mask_common.h
+
+libpacket_common_la_SOURCES = packet_common.c packet_common.h
+
+libthrmask_common_la_SOURCES = mask_common.c mask_common.h
+libthrmask_common_la_CFLAGS = $(AM_CFLAGS) -DTEST_THRMASK
+
+endif
+
+noinst_HEADERS = test_common_macros.h \
+ test_packet_custom.h \
+ test_packet_ipsec.h \
+ test_packet_ipv4.h \
+ test_packet_ipv4_with_crc.h \
+ test_packet_ipv6.h