aboutsummaryrefslogtreecommitdiff
path: root/example/simple_pipeline/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/simple_pipeline/Makefile.am')
-rw-r--r--example/simple_pipeline/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/example/simple_pipeline/Makefile.am b/example/simple_pipeline/Makefile.am
new file mode 100644
index 000000000..f258434aa
--- /dev/null
+++ b/example/simple_pipeline/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/example/Makefile.inc
+
+bin_PROGRAMS = odp_simple_pipeline
+
+odp_simple_pipeline_SOURCES = odp_simple_pipeline.c
+
+if test_example
+if ODP_PKTIO_PCAP
+TESTS = simple_pipeline_run.sh
+endif
+endif
+EXTRA_DIST = simple_pipeline_run.sh udp64.pcap
+
+# If building out-of-tree, make check will not copy the scripts and data to the
+# $(builddir) assuming that all commands are run locally. However this prevents
+# running tests on a remote target using LOG_COMPILER.
+# So copy all script and data files explicitly here.
+all-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ if [ -e $(srcdir)/$$f ]; then \
+ mkdir -p $(builddir)/$$(dirname $$f); \
+ cp -f $(srcdir)/$$f $(builddir)/$$f; \
+ fi \
+ done \
+ fi
+ ln -f -s $(top_srcdir)/platform/$(with_platform)/test/example/simple_pipeline/pktio_env \
+ pktio_env
+clean-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ rm -f $(builddir)/$$f; \
+ done \
+ fi