aboutsummaryrefslogtreecommitdiff
path: root/example/ping/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/ping/Makefile.am')
-rw-r--r--example/ping/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/example/ping/Makefile.am b/example/ping/Makefile.am
new file mode 100644
index 000000000..009b0993a
--- /dev/null
+++ b/example/ping/Makefile.am
@@ -0,0 +1,34 @@
+include $(top_srcdir)/example/Makefile.inc
+
+bin_PROGRAMS = odp_ping
+
+odp_ping_SOURCES = odp_ping.c
+
+if test_example
+if ODP_PKTIO_PCAP
+TESTS = ping_run.sh
+endif
+endif
+EXTRA_DIST = ping_run.sh icmp_echo_req.pcap
+
+# If building out-of-tree, make check will not copy the scripts and data to the
+# $(builddir) assuming that all commands are run locally. However this prevents
+# running tests on a remote target using LOG_COMPILER.
+# So copy all script and data files explicitly here.
+all-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ if [ -e $(srcdir)/$$f ]; then \
+ mkdir -p $(builddir)/$$(dirname $$f); \
+ cp -f $(srcdir)/$$f $(builddir)/$$f; \
+ fi \
+ done \
+ fi
+ ln -f -s $(top_srcdir)/platform/$(with_platform)/test/example/ping/pktio_env \
+ pktio_env
+clean-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ rm -f $(builddir)/$$f; \
+ done \
+ fi