aboutsummaryrefslogtreecommitdiff
path: root/example/l3fwd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'example/l3fwd/Makefile.am')
-rw-r--r--example/l3fwd/Makefile.am41
1 files changed, 30 insertions, 11 deletions
diff --git a/example/l3fwd/Makefile.am b/example/l3fwd/Makefile.am
index 422a3bf3a..80ad91911 100644
--- a/example/l3fwd/Makefile.am
+++ b/example/l3fwd/Makefile.am
@@ -1,20 +1,39 @@
include $(top_srcdir)/example/Makefile.inc
-bin_PROGRAMS = odp_l3fwd$(EXEEXT)
-odp_l3fwd_LDFLAGS = $(AM_LDFLAGS) -static
-odp_l3fwd_CFLAGS = $(AM_CFLAGS) -I${top_srcdir}/example -I${top_srcdir}/test
+bin_PROGRAMS = odp_l3fwd
-noinst_HEADERS = \
- $(top_srcdir)/example/l3fwd/odp_l3fwd_db.h \
- $(top_srcdir)/example/l3fwd/odp_l3fwd_lpm.h \
- $(top_srcdir)/example/example_debug.h
-
-dist_odp_l3fwd_SOURCES = odp_l3fwd.c odp_l3fwd_db.c odp_l3fwd_lpm.c
+odp_l3fwd_SOURCES = \
+ odp_l3fwd.c \
+ odp_l3fwd_db.c \
+ odp_l3fwd_lpm.c \
+ odp_l3fwd_db.h \
+ odp_l3fwd_lpm.h
if test_example
-if HAVE_PCAP
+if ODP_PKTIO_PCAP
TESTS = odp_l3fwd_run.sh
endif
endif
-
EXTRA_DIST = odp_l3fwd_run.sh udp64.pcap
+
+# If building out-of-tree, make check will not copy the scripts and data to the
+# $(builddir) assuming that all commands are run locally. However this prevents
+# running tests on a remote target using LOG_COMPILER.
+# So copy all script and data files explicitly here.
+all-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ if [ -e $(srcdir)/$$f ]; then \
+ mkdir -p $(builddir)/$$(dirname $$f); \
+ cp -f $(srcdir)/$$f $(builddir)/$$f; \
+ fi \
+ done \
+ fi
+ ln -f -s $(top_srcdir)/platform/$(with_platform)/test/example/l3fwd/pktio_env \
+ pktio_env
+clean-local:
+ if [ "x$(srcdir)" != "x$(builddir)" ]; then \
+ for f in $(EXTRA_DIST); do \
+ rm -f $(builddir)/$$f; \
+ done \
+ fi