aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 41 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 76ceb851e..8b65244c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,22 +1,46 @@
ACLOCAL_AMFLAGS=-I m4
-AUTOMAKE_OPTIONS = foreign
-AM_DISTCHECK_CONFIGURE_FLAGS = --enable-test-cpp \
- --enable-test-example \
- --enable-test-helper \
- --enable-test-perf \
- --enable-test-perf-proc \
- --enable-test-vald \
- --enable-user-guides \
- --with-testdir
-
-#@with_platform@ works alone in subdir but not as part of a path???
-SUBDIRS = @platform_with_platform@ \
+AM_DISTCHECK_CONFIGURE_FLAGS = --enable-user-guides \
+ --enable-helper-linux
+
+if PLATFORM_IS_LINUX_GENERIC
+PLATFORM_DIR = platform/linux-generic
+PLATFORM_DUMPCONF_DIR = platform/linux-generic/dumpconfig
+PLATFORM_TEST_DIR = platform/linux-generic/test
+PLATFORM_EXAMPLE_DIR = platform/linux-generic/example
+endif
+
+SUBDIRS = \
+ include \
+ $(PLATFORM_DIR) \
+ $(PLATFORM_DUMPCONF_DIR) \
helper \
- helper/test \
- doc \
- example . \
- test
+ doc
+
+# Tests are run in this SUBDIRS order. The intention is to run validation tests first,
+# then example/performance/platform specific tests.
+if WITH_TESTS
+SUBDIRS += test/common
+SUBDIRS += test/miscellaneous
+SUBDIRS += test/validation
+endif
+
+if WITH_EXAMPLES
+SUBDIRS += example
+SUBDIRS += $(PLATFORM_EXAMPLE_DIR)
+endif
+
+if WITH_TESTS
+SUBDIRS += test/performance
+SUBDIRS += helper/test
+SUBDIRS += $(PLATFORM_TEST_DIR)
+endif
@DX_RULES@
-EXTRA_DIST = bootstrap $(DX_CONFIG) CHANGELOG config/README
+EXTRA_DIST = bootstrap CHANGELOG config/README
+
+distcheck-hook:
+ if test -n "$(DX_CLEANFILES)" ; \
+ then \
+ $(MAKE) doxygen-doc ; \
+ fi