aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristophe Milard <christophe.milard@linaro.org>2015-06-10 18:54:23 +0200
committerMaxim Uvarov <maxim.uvarov@linaro.org>2015-06-11 17:18:55 +0300
commit7cd8a605dc70cc4bbca4ba59c44c662ba5402781 (patch)
tree07f78748ba4d756a93bbb091b5fb614a723678a6 /Makefile.am
parented173ed785c69be66339b01e4c10c64279616cce (diff)
validation: changing build order
When tests will be ran from the platform side, they will use platform agnostic tests from the validation side: i.e. -the validation side must be build before the platform test side. And the platform agnostic tests uses ODP. The building order must therefore be as follows: 1) <platform> (i.e. ODP) 2) validation (i.e. common tests) 3) <platform>/test (i.e. the platform specific test setup and tests) Saddly, writing SUBDIRS=platform/@with_platform@ does not work with autotools, which leads to a bit of clutter in configure.ac. Hopefully changed if things move around in the future... Signed-off-by: Christophe Milard <christophe.milard@linaro.org> Reviewed-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Stuart Haslam <stuart.haslam@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b9b251704..2c8a9d643 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,14 @@
ACLOCAL_AMFLAGS=-I m4
AUTOMAKE_OPTIONS = foreign
-SUBDIRS = doc platform example test helper scripts
+#@with_platform@ works alone in subdir but not as part of a path???
+SUBDIRS = @platform_with_platform@ \
+ test \
+ @platform_with_platform_test@ \
+ helper \
+ doc \
+ example \
+ scripts
include $(top_srcdir)/aminclude.am