aboutsummaryrefslogtreecommitdiff
path: root/ports/nrf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports/nrf/Makefile')
-rw-r--r--ports/nrf/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/ports/nrf/Makefile b/ports/nrf/Makefile
index e331c95ad..3705409bc 100644
--- a/ports/nrf/Makefile
+++ b/ports/nrf/Makefile
@@ -41,7 +41,7 @@ QSTR_DEFS = qstrdefsport.h $(BUILD)/pins_qstr.h
# include py core make definitions
include ../../py/py.mk
-
+MICROPY_FATFS ?= 0
FATFS_DIR = lib/oofatfs
MPY_CROSS = ../../mpy-cross/mpy-cross
MPY_TOOL = ../../tools/mpy-tool.py
@@ -158,10 +158,16 @@ SRC_LIB += $(addprefix lib/,\
utils/pyexec.c \
utils/interrupt_char.c \
timeutils/timeutils.c \
- oofatfs/ff.c \
- oofatfs/option/unicode.c \
)
+ifeq ($(MICROPY_FATFS), 1)
+SRC_LIB += $(addprefix lib/,\
+ oofatfs/ff.c \
+ oofatfs/option/unicode.c \
+ )
+endif
+
+
SRC_NRFX += $(addprefix lib/nrfx/drivers/src/,\
prs/nrfx_prs.c \
nrfx_uart.c \