summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 54f30d8..d588779 100755
--- a/debian/rules
+++ b/debian/rules
@@ -106,6 +106,11 @@ DEB_BUILDDIR := $(CURDIR)/debian/build
LOGROTATE = $(basename $(basename $(notdir $(wildcard daemon/libvirtd*.logrotate.in))))
EXAMPLES_DIR = $(CURDIR)/debian/libvirt-doc/usr/share/doc/libvirt-doc/examples/
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+MFLAGS=-j$(NUMJOBS)
+endif
+
%:
dh $@ --builddirectory=$(DEB_BUILDDIR)
@@ -162,8 +167,8 @@ override_dh_strip:
dh_strip --dbg-package=libvirt0-dbg
override_dh_auto_build:
- dh_auto_build -a -i
- DEB_BUILDDIR=$(DEB_BUILDDIR) make --parallel -f debian/python.mk build
+ dh_auto_build -a -i --parallel
+ DEB_BUILDDIR=$(DEB_BUILDDIR) make $(MFLAGS) -f debian/python.mk build
override_dh_auto_clean:
[ ! -f Makefile ] || dh_auto_clean