aboutsummaryrefslogtreecommitdiff
path: root/openembedded-lkft-linux-developer.yaml
diff options
context:
space:
mode:
authorDaniel Díaz <daniel.diaz@linaro.org>2019-05-20 16:41:54 -0500
committerDaniel Díaz <daniel.diaz@linaro.org>2019-05-20 17:12:14 -0500
commit7b3f438acfd210d1da135763a0add96929b5acc8 (patch)
tree4782ffe460a5d68d271aa34eba24bef1f8d72d9d /openembedded-lkft-linux-developer.yaml
parent5ddbee657a5dbc8553e4cdd18196428f2004eb07 (diff)
openembedded-lkft: developer: Use Juno for Arm 64-bits
Change-Id: I97fa2d35564eaf815b5378fa1c9c7e0bac23e497 Signed-off-by: Daniel Díaz <daniel.diaz@linaro.org>
Diffstat (limited to 'openembedded-lkft-linux-developer.yaml')
-rw-r--r--openembedded-lkft-linux-developer.yaml23
1 files changed, 10 insertions, 13 deletions
diff --git a/openembedded-lkft-linux-developer.yaml b/openembedded-lkft-linux-developer.yaml
index c205885e2c..79b2e0dc91 100644
--- a/openembedded-lkft-linux-developer.yaml
+++ b/openembedded-lkft-linux-developer.yaml
@@ -29,7 +29,7 @@
and can be <b>tested</b> the same way <b>LKFT</b> runs on the regular
builds.</p>
<p>You can compare your test results with existing runs on actual hardware:
- <b>arm (X15)</b>, <b>arm64 (HiKey)</b> and <b>x86 (Xeon
+ <b>arm (X15)</b>, <b>arm64 (Juno)</b> and <b>x86 (Xeon
E3-1220)</b>. A description of the hardware can be found
<a href="https://lkft.linaro.org/boards/">here</a>.</p>
<p>This is more or less how it goes:
@@ -55,9 +55,9 @@
(Please note that you need to log-in to Jenkins first if you haven't.)</p>
<p>Note that these config fragments are added to your defconfig:
<ul>
- <li><a href="https://github.com/96boards/meta-96boards/blob/master/recipes-kernel/linux/linux-hikey-aosp/distro-overrides.config">distro</a></li>
- <li><a href="https://github.com/96boards/meta-96boards/blob/master/recipes-kernel/linux/linux-hikey-aosp/systemd.config">systemd</a></li>
- <li><a href="https://github.com/96boards/meta-96boards/blob/master/recipes-kernel/linux/linux-hikey-aosp/lkft.config">lkft</a></li>
+ <li><a href="https://github.com/Linaro/meta-lkft/blob/sumo/recipes-kernel/linux/files/distro-overrides.config">distro</a></li>
+ <li><a href="https://github.com/Linaro/meta-lkft/blob/sumo/recipes-kernel/linux/files/systemd.config">systemd</a></li>
+ <li><a href="https://github.com/Linaro/meta-lkft/blob/sumo/recipes-kernel/linux/files/lkft.config">lkft</a></li>
<li><a href="https://github.com/torvalds/linux/blob/master/Makefile#L1182">kselftest-merge</a></li>
</ul>
</p>
@@ -84,12 +84,12 @@
- choice:
name: TARGET_MACHINE
choices:
- - 'hikey'
+ - 'juno'
- 'x15'
- 'x86_64'
- 'i386'
description: |
- <b>[MANDATORY]</b> Target machine. Can be hikey (arm64), x15 (arm), x86_64, or i386 (32-bits).
+ <b>[MANDATORY]</b> Target machine. Can be juno (arm64), x15 (arm), x86_64, or i386 (32-bits).
- string:
name: KERNEL_CONFIG
default: ''
@@ -97,7 +97,7 @@
<b>[OPTIONAL]</b> Kernel config file<br/>
File to use from arch/${ARCH}/configs/ as base kernel configuration. If ommited the default
kernel config will be used:<br/>
- - defconfig on HiKey<br/>
+ - defconfig on Juno<br/>
- multi_v7_defconfig on X15<br/>
- x86_64_defconfig on x86_64<br/>
- i386_defconfig on i386<br/>
@@ -162,12 +162,9 @@
# Mapping for TARGET_MACHINE -> MACHINE/DEVICE_TYPE
# Set a default config if it isn't given
case "${TARGET_MACHINE}" in
- hikey)
- MACHINE=hikey
- DEVICE_TYPE=hi6220-hikey
- # or Juno? (it is supported from in 4.4 kernel while HiKey isn't)
- #MACHINE=juno
- #DEVICE_TYPE=juno-r2
+ juno)
+ MACHINE=juno
+ DEVICE_TYPE=juno-r2
[ -z "${KERNEL_CONFIG}" ] && KERNEL_CONFIG=defconfig
;;
x15)