summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch26
-rw-r--r--debian/patches/series1
3 files changed, 29 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b94e1d83c..860610a11 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -54,6 +54,8 @@ linux (3.16.2-3) UNRELEASED; urgency=medium
COMEDI_AMPLC_PC263_ISA, COMEDI_DAS08_ISA, COMEDI_NI_LABPC_ISA as modules
* [i386] speakup: Enable SPEAKUP_SYNTH_DECPC as module
* [!x86] staging: Enable R8712U, R8188EU as modules (Closes: #742055, #760859)
+ * i2o: Disable I2O_EXT_ADAPTEC on 64-bit, as it assumes 32-bit virtual
+ addresses
[ Ian Campbell ]
* [armel/orion5x] udeb: Include mvmdio in nic-modules udeb.
diff --git a/debian/patches/debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch b/debian/patches/debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch
new file mode 100644
index 000000000..b766ca04f
--- /dev/null
+++ b/debian/patches/debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch
@@ -0,0 +1,26 @@
+From: Ben Hutchings <ben@decadent.org.uk>
+Date: Fri, 12 Sep 2014 13:24:26 +0100
+Subject: i2o: Disable I2O_EXT_ADAPTEC on 64-bit
+
+The code it enables works uses 32-bit numbers for userland virtual
+addresses:
+
+In file included from /tmp/buildd/linux-3.16.2/drivers/message/i2o/config-osm.c:39:0:
+/tmp/buildd/linux-3.16.2/drivers/message/i2o/i2o_config.c: In function 'i2o_cfg_passthru':
+/tmp/buildd/linux-3.16.2/drivers/message/i2o/i2o_config.c:893:19: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
+ (p->virt, (void __user *)sg[i].addr_bus,
+ ^
+/tmp/buildd/linux-3.16.2/drivers/message/i2o/i2o_config.c:953:10: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
+ ((void __user *)sg[j].addr_bus, sg_list[j].virt,
+ ^
+
+--- a/drivers/message/i2o/Kconfig
++++ b/drivers/message/i2o/Kconfig
+@@ -37,6 +37,7 @@ config I2O_LCT_NOTIFY_ON_CHANGES
+
+ config I2O_EXT_ADAPTEC
+ bool "Enable Adaptec extensions"
++ depends on !64BIT || BROKEN
+ default y
+ ---help---
+ Say Y for support of raidutils for Adaptec I2O controllers. You also
diff --git a/debian/patches/series b/debian/patches/series
index 4a43e77a0..0756cdeff 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -110,3 +110,4 @@ features/all/efi-autoload-efivars.patch
features/x86/x86-make-x32-syscall-support-conditional.patch
features/all/virtio-scsi-Implement-change_queue_depth-for-virtscs.patch
debian/revert-staging-sm7xxfb-remove-driver.patch
+debian/i2o-disable-i2o_ext_adaptec-on-64bit.patch