summaryrefslogtreecommitdiff
path: root/debian/rules.real
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2013-03-27 03:51:48 +0000
committerBen Hutchings <benh@debian.org>2013-03-27 03:51:48 +0000
commit55da5d676ad50c5e99214f370754a79051fb4f64 (patch)
treeb44b65885bfb54fcfc1feb748fb0d1cf54a34852 /debian/rules.real
parent3937ca5280e4a826727ff4659b92337f7429caa9 (diff)
parentd3d3caa09f22542b92c58b534244e029268554b7 (diff)
Merge changes from sid up to 3.2.41-2
svn path=/dists/trunk/linux/; revision=19951
Diffstat (limited to 'debian/rules.real')
-rw-r--r--debian/rules.real8
1 files changed, 5 insertions, 3 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 54cdba6d2..b3ce86362 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -196,6 +196,7 @@ install-doc: $(STAMPS_DIR)/build-doc
mkdir -p $(OUT_DIR)
cp -a CREDITS MAINTAINERS README REPORTING-BUGS Documentation $(OUT_DIR)
rm -rf $(OUT_DIR)/Documentation/DocBook
+ set -o pipefail; \
cd $(DIR)/Documentation/DocBook; \
find * -name '*.html' -print \
| \
@@ -208,6 +209,7 @@ install-manual: DIR=$(BUILD_DIR)/build-doc
install-manual: DH_OPTIONS = -p$(PACKAGE_NAME)
install-manual: $(STAMPS_DIR)/build-doc
dh_prep
+ set -o pipefail; \
find $(DIR)/Documentation/DocBook/man/ -name '*.9' | xargs dh_installman
+$(MAKE_SELF) install-base GENCONTROL_ARGS='$(call DEFINE_MULTIARCH,foreign)'
@@ -229,13 +231,12 @@ install-headers_$(ARCH)_$(FEATURESET): $(STAMPS_DIR)/source_$(FEATURESET)
dh_testroot
dh_prep
+ set -o pipefail; \
cd $(SOURCE_DIR); \
( \
echo Makefile; \
find arch/$(KERNEL_ARCH) -maxdepth 1 -name 'Makefile*' -print; \
- find arch/$(KERNEL_ARCH) -name 'module.lds' -print; \
- find arch/$(KERNEL_ARCH)/Kbuild.platforms -print; \
- find arch/$(KERNEL_ARCH) -name 'Platform' -print; \
+ find arch/$(KERNEL_ARCH) \( -name 'module.lds' -o -name 'Kbuild.platforms' -o -name 'Platform' \) -print; \
find $$(find arch/$(KERNEL_ARCH) \( -name include -o -name scripts \) -type d -print) -print; \
find include -print; \
) \
@@ -358,6 +359,7 @@ install-image_$(ARCH)_$(FEATURESET)_$(FLAVOUR)_plain:
ifeq ($(MODULES),True)
+$(MAKE_CLEAN) -C $(DIR) modules_install DEPMOD='$(CURDIR)/debian/bin/no-depmod' INSTALL_MOD_PATH='$(CURDIR)'/$(PACKAGE_DIR) INSTALL_MOD_STRIP=1
ifeq ($(DEBUG),True)
+ set -o pipefail; \
find $(PACKAGE_DIR) -name '*.ko' | sed 's|$(PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/kernel/||' | while read module ; do \
objcopy --add-gnu-debuglink=$(DIR)/$$module $(PACKAGE_DIR)/lib/modules/$(REAL_VERSION)/kernel/$$module || exit; \
done