summaryrefslogtreecommitdiff
path: root/debian/patches/debian/version.patch
diff options
context:
space:
mode:
authorMaximilian Attems <maks@debian.org>2015-02-08 12:26:35 +0000
committerMaximilian Attems <maks@debian.org>2015-02-08 12:26:35 +0000
commit557583e45921218c31245d837fdcb3c4bd41f694 (patch)
tree08c1daeb2017fc6be9b5e2c0cc46573c22418adb /debian/patches/debian/version.patch
parent736c464e72e56d35112786cda0a39139d2aec781 (diff)
version.patch : fixup
Signed-off-by: maximilian attems <maks@debian.org> svn path=/dists/trunk/linux/; revision=22349
Diffstat (limited to 'debian/patches/debian/version.patch')
-rw-r--r--debian/patches/debian/version.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index c07b9aaeb..3d48b63f8 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -9,7 +9,7 @@ are set.
--- a/Makefile
+++ b/Makefile
-@@ -963,7 +963,7 @@ endif
+@@ -973,7 +973,7 @@ endif
prepare2: prepare3 outputmakefile asm-generic
prepare1: prepare2 $(version_h) include/generated/utsrelease.h \
@@ -18,7 +18,7 @@ are set.
$(cmd_crmodverdir)
archprepare: archheaders archscripts prepare1 scripts_basic
-@@ -995,12 +995,25 @@ define filechk_version.h
+@@ -1005,13 +1005,26 @@ define filechk_version.h
echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
endef
@@ -34,6 +34,7 @@ are set.
+
$(version_h): $(srctree)/Makefile FORCE
$(call filechk,version.h)
+ $(Q)rm -f $(old_version_h)
include/generated/utsrelease.h: include/config/kernel.release FORCE
$(call filechk,utsrelease.h)
@@ -90,15 +91,15 @@ are set.
regs->ar_unat, regs->ar_pfs, regs->ar_rsc);
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
-@@ -37,6 +37,7 @@
- #include <linux/personality.h>
+@@ -38,6 +38,7 @@
#include <linux/random.h>
#include <linux/hw_breakpoint.h>
+ #include <linux/uaccess.h>
+#include <generated/package.h>
#include <asm/pgtable.h>
- #include <asm/uaccess.h>
-@@ -1004,8 +1005,9 @@ void show_regs(struct pt_regs * regs)
+ #include <asm/io.h>
+@@ -1001,8 +1002,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
regs->nip, regs->link, regs->ctr);