summaryrefslogtreecommitdiff
path: root/debian/patches/debian/version.patch
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2013-06-02 18:14:09 +0000
committerBen Hutchings <benh@debian.org>2013-06-02 18:14:09 +0000
commit41bc6e789537469a575ad49b5e904d783b58c9c8 (patch)
tree5f95d0cdffc5007a3d5ec454a870d9995c0d0bd8 /debian/patches/debian/version.patch
parent15dc8c6034cee8bd52ec288e31950ebf2b2b126b (diff)
Update to 3.10-rc3
Refresh/drop various patches. aufs: Update to aufs3.x-rcN-20130520 svn path=/dists/trunk/linux/; revision=20176
Diffstat (limited to 'debian/patches/debian/version.patch')
-rw-r--r--debian/patches/debian/version.patch159
1 files changed, 23 insertions, 136 deletions
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index bbfba526c..2cffe6034 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -8,7 +8,7 @@ are set.
--- a/Makefile
+++ b/Makefile
-@@ -822,7 +822,7 @@ endif
+@@ -826,7 +826,7 @@ endif
prepare2: prepare3 outputmakefile asm-generic
prepare1: prepare2 $(version_h) include/generated/utsrelease.h \
@@ -17,7 +17,7 @@ are set.
$(cmd_crmodverdir)
archprepare: archheaders archscripts prepare1 scripts_basic
-@@ -854,12 +854,25 @@ define filechk_version.h
+@@ -858,12 +858,25 @@ define filechk_version.h
echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
endef
@@ -43,46 +43,6 @@ are set.
PHONY += headerdep
headerdep:
$(Q)find $(srctree)/include/ -name '*.h' | xargs --max-args 1 \
---- a/arch/s390/kernel/traps.c
-+++ b/arch/s390/kernel/traps.c
-@@ -31,6 +31,7 @@
- #include <linux/kprobes.h>
- #include <linux/bug.h>
- #include <linux/utsname.h>
-+#include <generated/package.h>
- #include <asm/uaccess.h>
- #include <asm/io.h>
- #include <linux/atomic.h>
-@@ -179,11 +180,12 @@ static void show_last_breaking_event(str
- */
- void dump_stack(void)
- {
-- printk("CPU: %d %s %s %.*s\n",
-+ printk("CPU: %d %s %s %.*s%s\n",
- task_thread_info(current)->cpu, print_tainted(),
- init_utsname()->release,
- (int)strcspn(init_utsname()->version, " "),
-- init_utsname()->version);
-+ init_utsname()->version,
-+ LINUX_PACKAGE_ID);
- printk("Process %s (pid: %d, task: %p, ksp: %p)\n",
- current->comm, current->pid, current,
- (void *) current->thread.ksp);
-@@ -229,11 +231,12 @@ void show_registers(struct pt_regs *regs
-
- void show_regs(struct pt_regs *regs)
- {
-- printk("CPU: %d %s %s %.*s\n",
-+ printk("CPU: %d %s %s %.*s%s\n",
- task_thread_info(current)->cpu, print_tainted(),
- init_utsname()->release,
- (int)strcspn(init_utsname()->version, " "),
-- init_utsname()->version);
-+ init_utsname()->version,
-+ LINUX_PACKAGE_ID);
- printk("Process %s (pid: %d, task: %p, ksp: %p)\n",
- current->comm, current->pid, current,
- (void *) current->thread.ksp);
--- a/arch/x86/um/sysrq_64.c
+++ b/arch/x86/um/sysrq_64.c
@@ -8,6 +8,7 @@
@@ -105,55 +65,6 @@ are set.
printk(KERN_INFO "RIP: %04lx:[<%016lx>]\n", PT_REGS_CS(regs) & 0xffff,
PT_REGS_IP(regs));
printk(KERN_INFO "RSP: %016lx EFLAGS: %08lx\n", PT_REGS_SP(regs),
---- a/arch/x86/kernel/process.c
-+++ b/arch/x86/kernel/process.c
-@@ -19,6 +19,7 @@
- #include <linux/cpuidle.h>
- #include <trace/events/power.h>
- #include <linux/hw_breakpoint.h>
-+#include <generated/package.h>
- #include <asm/cpu.h>
- #include <asm/apic.h>
- #include <asm/syscalls.h>
-@@ -135,11 +136,12 @@ void show_regs_common(void)
- /* Board Name is optional */
- board = dmi_get_system_info(DMI_BOARD_NAME);
-
-- printk(KERN_DEFAULT "Pid: %d, comm: %.20s %s %s %.*s %s %s%s%s\n",
-+ printk(KERN_DEFAULT "Pid: %d, comm: %.20s %s %s %.*s%s %s %s%s%s\n",
- current->pid, current->comm, print_tainted(),
- init_utsname()->release,
- (int)strcspn(init_utsname()->version, " "),
- init_utsname()->version,
-+ LINUX_PACKAGE_ID,
- vendor, product,
- board ? "/" : "",
- board ? board : "");
---- a/arch/x86/kernel/dumpstack.c
-+++ b/arch/x86/kernel/dumpstack.c
-@@ -15,6 +15,7 @@
- #include <linux/bug.h>
- #include <linux/nmi.h>
- #include <linux/sysfs.h>
-+#include <generated/package.h>
-
- #include <asm/stacktrace.h>
-
-@@ -188,11 +189,12 @@ void dump_stack(void)
- unsigned long stack;
-
- bp = stack_frame(current, NULL);
-- printk("Pid: %d, comm: %.20s %s %s %.*s\n",
-+ printk("Pid: %d, comm: %.20s %s %s %.*s%s\n",
- current->pid, current->comm, print_tainted(),
- init_utsname()->release,
- (int)strcspn(init_utsname()->version, " "),
-- init_utsname()->version);
-+ init_utsname()->version,
-+ LINUX_PACKAGE_ID);
- show_trace(NULL, NULL, &stack, bp);
- }
- EXPORT_SYMBOL(dump_stack);
--- a/arch/ia64/kernel/process.c
+++ b/arch/ia64/kernel/process.c
@@ -30,6 +30,7 @@
@@ -164,10 +75,10 @@ are set.
#include <asm/cpu.h>
#include <asm/delay.h>
-@@ -113,9 +114,9 @@ show_regs (struct pt_regs *regs)
+@@ -103,9 +104,9 @@ show_regs (struct pt_regs *regs)
print_modules();
- printk("\nPid: %d, CPU %d, comm: %20s\n", task_pid_nr(current),
- smp_processor_id(), current->comm);
+ printk("\n");
+ show_regs_print_info(KERN_DEFAULT);
- printk("psr : %016lx ifs : %016lx ip : [<%016lx>] %s (%s)\n",
+ printk("psr : %016lx ifs : %016lx ip : [<%016lx>] %s (%s%s)\n",
regs->cr_ipsr, regs->cr_ifs, ip, print_tainted(),
@@ -176,31 +87,6 @@ are set.
print_symbol("ip is at %s\n", ip);
printk("unat: %016lx pfs : %016lx rsc : %016lx\n",
regs->ar_unat, regs->ar_pfs, regs->ar_rsc);
---- a/arch/arm/kernel/process.c
-+++ b/arch/arm/kernel/process.c
-@@ -32,6 +32,7 @@
- #include <linux/hw_breakpoint.h>
- #include <linux/cpuidle.h>
- #include <linux/leds.h>
-+#include <generated/package.h>
-
- #include <asm/cacheflush.h>
- #include <asm/idmap.h>
-@@ -278,11 +279,12 @@ void __show_regs(struct pt_regs *regs)
- unsigned long flags;
- char buf[64];
-
-- printk("CPU: %d %s (%s %.*s)\n",
-+ printk("CPU: %d %s (%s %.*s%s)\n",
- raw_smp_processor_id(), print_tainted(),
- init_utsname()->release,
- (int)strcspn(init_utsname()->version, " "),
-- init_utsname()->version);
-+ init_utsname()->version,
-+ LINUX_PACKAGE_ID);
- print_symbol("PC is at %s\n", instruction_pointer(regs));
- print_symbol("LR is at %s\n", regs->ARM_lr);
- printk("pc : [<%08lx>] lr : [<%08lx>] psr: %08lx\n"
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
@@ -38,6 +38,7 @@
@@ -211,7 +97,7 @@ are set.
#include <asm/pgtable.h>
#include <asm/uaccess.h>
-@@ -643,8 +644,9 @@ void show_regs(struct pt_regs * regs)
+@@ -842,8 +843,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
regs->nip, regs->link, regs->ctr);
@@ -223,27 +109,28 @@ are set.
printk("MSR: "REG" ", regs->msr);
printbits(regs->msr, msr_bits);
printk(" CR: %08lx XER: %08lx\n", regs->ccr, regs->xer);
---- a/arch/sh/kernel/process_32.c
-+++ b/arch/sh/kernel/process_32.c
-@@ -23,6 +23,7 @@
- #include <linux/hw_breakpoint.h>
- #include <linux/prefetch.h>
- #include <linux/stackprotector.h>
+--- a/kernel/printk.c
++++ b/kernel/printk.c
+@@ -45,6 +45,7 @@
+ #include <linux/poll.h>
+ #include <linux/irq_work.h>
+ #include <linux/utsname.h>
+#include <generated/package.h>
+
#include <asm/uaccess.h>
- #include <asm/mmu_context.h>
- #include <asm/fpu.h>
-@@ -33,10 +34,11 @@ void show_regs(struct pt_regs * regs)
+
+@@ -2883,11 +2884,12 @@ void __init dump_stack_set_arch_desc(con
+ */
+ void dump_stack_print_info(const char *log_lvl)
{
- printk("\n");
- printk("Pid : %d, Comm: \t\t%s\n", task_pid_nr(current), current->comm);
-- printk("CPU : %d \t\t%s (%s %.*s)\n\n",
-+ printk("CPU : %d \t\t%s (%s %.*s%s)\n\n",
- smp_processor_id(), print_tainted(), init_utsname()->release,
+- printk("%sCPU: %d PID: %d Comm: %.20s %s %s %.*s\n",
++ printk("%sCPU: %d PID: %d Comm: %.20s %s %s %.*s%s\n",
+ log_lvl, raw_smp_processor_id(), current->pid, current->comm,
+ print_tainted(), init_utsname()->release,
(int)strcspn(init_utsname()->version, " "),
- init_utsname()->version);
+ init_utsname()->version,
+ LINUX_PACKAGE_ID);
- print_symbol("PC is at %s\n", instruction_pointer(regs));
- print_symbol("PR is at %s\n", regs->pr);
+ if (dump_stack_arch_desc_str[0] != '\0')
+ printk("%sHardware name: %s\n",