summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2015-11-12 14:59:37 +0000
committerBen Hutchings <ben@decadent.org.uk>2015-11-12 14:59:37 +0000
commit5269f93afe9d408e08c842eef261071e447ba7de (patch)
tree73eb7369737aff149ef485def5fb208a785e5e73
parentb531af692925f1f2f905b16b3b26381b4bb15d75 (diff)
firmware_class: Fix condition in directory search loop (Closes: #804862)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/all/firmware_class-log-every-success-and-failure.patch6
2 files changed, 3 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 438e035ef..a528f283f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ linux (4.3-1~exp2) UNRELEASED; urgency=medium
* debian/control: Add ':any' to Build-Depends on python3, to support cross-
bootstrap
* [s390*] Update linux-compiler metapackage to gcc-4.9
+ * firmware_class: Fix condition in directory search loop (Closes: #804862)
[ Ian Campbell ]
* [armel/orion5x] Enable Device Tree for orion5x. Patch from Roger Shimizu
diff --git a/debian/patches/bugfix/all/firmware_class-log-every-success-and-failure.patch b/debian/patches/bugfix/all/firmware_class-log-every-success-and-failure.patch
index 4663faad5..abb0b704b 100644
--- a/debian/patches/bugfix/all/firmware_class-log-every-success-and-failure.patch
+++ b/debian/patches/bugfix/all/firmware_class-log-every-success-and-failure.patch
@@ -23,13 +23,11 @@ format to detect missing firmware.
---
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
-@@ -340,17 +340,20 @@ static int fw_get_filesystem_firmware(st
- }
+@@ -340,16 +340,19 @@ static int fw_get_filesystem_firmware(st
rc = fw_read_file_contents(file, buf);
fput(file);
-- if (rc)
+ if (rc)
- dev_warn(device, "firmware, attempted to load %s, but failed with error %d\n",
-+ if (!rc)
+ dev_dbg(device, "firmware, attempted to load %s, but failed with error %d\n",
path, rc);
else