summaryrefslogtreecommitdiff
path: root/gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch')
-rw-r--r--gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch b/gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch
new file mode 100644
index 0000000..b626dd0
--- /dev/null
+++ b/gator-module-5.9/debian/patches/gator-driver-hack-makefile-to-search-for-mali-trace-headers.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile b/Makefile
+index e521b99..8824f8e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,6 +16,16 @@ gator-y := gator_main.o \
+
+ gator-y += gator_events_mmaped.o
+
++ifeq ($(GATOR_WITH_MALI_SUPPORT),)
++ifeq ($(GATOR_MALI_INCLUDE),)
++GATOR_MALI_INCLUDE = $(abspath $(shell find -L . -name "mali_linux_trace.h" | sed -n -e '1s,\(.*\)/linux/mali_linux_trace.h$$,\1,p'))
++endif
++ifneq ($(GATOR_MALI_INCLUDE),)
++GATOR_WITH_MALI_SUPPORT = MALI_400 # for now, assume all devices with Mali have the Mali-400
++EXTRA_CFLAGS += -I$(GATOR_MALI_INCLUDE)
++endif
++endif
++
+ ifneq ($(GATOR_WITH_MALI_SUPPORT),)
+ ifeq ($(GATOR_WITH_MALI_SUPPORT),MALI_T6xx)
+ gator-y += gator_events_mali_t6xx.o
+--
+1.7.9
+