summaryrefslogtreecommitdiff
path: root/gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch')
-rw-r--r--gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch b/gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch
new file mode 100644
index 0000000..cac0197
--- /dev/null
+++ b/gator-daemon-5.9/debian/patches/gator-daemon-compiler-options-for-armhf.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 4aaf219..d73d95b 100644
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,7 @@ CPP=$(CROSS_COMPILE)g++
+ # -std=c++98 is the 1998 c++ standard
+ # -march=armv5t is required to set the minimum architecture
+ # -mthumb-interwork is required for interworking to ARM or Thumb stdlibc
+-CFLAGS=-O3 -Wall -Werror -march=armv5t -mthumb-interwork
++CFLAGS=-O3 -Wall -Werror
+ TARGET=gatord
+ CPP_SRC = $(wildcard *.cpp)
+ TGT_OBJS = $(CPP_SRC:%.cpp=%.o)