aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2014-02-21 17:10:15 -0600
committerTom Gall <tom.gall@linaro.org>2014-02-21 17:10:15 -0600
commit0bb99edcb9fccd752370e7a5c1ee7616fce2b698 (patch)
treee3c01b07a94b43a871d5d00cfbf015164b731997
parentea47480fbcdcfebbd4bb47d150789e42061bc54c (diff)
Add re2 an efficient, principled regular expression library.
-rw-r--r--meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch27
-rw-r--r--meta-linaro/recipes-devtools/re2/re2_20130115.bb25
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch b/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch
new file mode 100644
index 0000000..111ab25
--- /dev/null
+++ b/meta-linaro/recipes-devtools/re2/re2/0001-tgall-enable-cross.patch
@@ -0,0 +1,27 @@
+Index: re2/Makefile
+===================================================================
+--- re2.orig/Makefile
++++ re2/Makefile
+@@ -9,18 +9,18 @@ all: obj/libre2.a obj/so/libre2.so
+ # CCPCRE=-I/usr/local/include -DUSEPCRE
+ # LDPCRE=-L/usr/local/lib -lpcre
+
+-CXX=g++
++# CXX=g++
+ CXXFLAGS=-Wall -O3 -g -pthread # can override
+ RE2_CXXFLAGS=-Wno-sign-compare -c -I. $(CCPCRE) # required
+ LDFLAGS=-pthread
+-AR=ar
++#AR=ar
+ ARFLAGS=rsc
+-NM=nm
++#NM=nm
+ NMFLAGS=-p
+
+ # Variables mandated by GNU, the arbiter of all good taste on the internet.
+ # http://www.gnu.org/prep/standards/standards.html
+-prefix=/usr/local
++prefix=/usr
+ exec_prefix=$(prefix)
+ bindir=$(exec_prefix)/bin
+ includedir=$(prefix)/include
diff --git a/meta-linaro/recipes-devtools/re2/re2_20130115.bb b/meta-linaro/recipes-devtools/re2/re2_20130115.bb
new file mode 100644
index 0000000..0555dd2
--- /dev/null
+++ b/meta-linaro/recipes-devtools/re2/re2_20130115.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "An efficient, principled regular expression library"
+HOMEPAGE = "https://code.google.com/p/re2/"
+
+LICENSE = ""
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b5c31eb512bdf3cb11ffd5713963760"
+
+SRC_URI = "https://re2.googlecode.com/files/re2-${PV}.tgz \
+ file://0001-tgall-enable-cross.patch "
+SECTION = "libs"
+
+PR = "r1"
+S = "${WORKDIR}/re2"
+
+SRC_URI[md5sum] = "ef66646926e6cb8f11f277b286eac579"
+SRC_URI[sha256sum] = "a95d83ed8203817587f7cc368b6f7199d8a4b1558372c306b07201058b92e1fe"
+
+inherit autotools
+
+FILES_${PN} = "/usr/lib/libre2.so*"
+FILES_${PN} += "/usr/include/re2/filtered_re2.h"
+FILES_${PN} += "/usr/include/re2/re2.h"
+FILES_${PN} += "/usr/include/re2/set.h"
+FILES_${PN} += "/usr/include/re2/stringpiece.h"
+FILES_${PN} += "/usr/include/re2/variadic_function.h"
+