aboutsummaryrefslogtreecommitdiff
path: root/trace/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'trace/meson.build')
-rw-r--r--trace/meson.build21
1 files changed, 7 insertions, 14 deletions
diff --git a/trace/meson.build b/trace/meson.build
index 843ea14495..8569e8a0c4 100644
--- a/trace/meson.build
+++ b/trace/meson.build
@@ -11,20 +11,17 @@ foreach dir : [ '.' ] + trace_events_subdirs
trace_h = custom_target(fmt.format('trace', 'h'),
output: fmt.format('trace', 'h'),
input: trace_events_file,
- command: [ tracetool, group, '--format=h', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, group, '--format=h', '@INPUT@', '@OUTPUT@' ])
genh += trace_h
trace_c = custom_target(fmt.format('trace', 'c'),
output: fmt.format('trace', 'c'),
input: trace_events_file,
- command: [ tracetool, group, '--format=c', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, group, '--format=c', '@INPUT@', '@OUTPUT@' ])
if 'CONFIG_TRACE_UST' in config_host
trace_ust_h = custom_target(fmt.format('trace-ust', 'h'),
output: fmt.format('trace-ust', 'h'),
input: trace_events_file,
- command: [ tracetool, group, '--format=ust-events-h', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, group, '--format=ust-events-h', '@INPUT@', '@OUTPUT@' ])
trace_ss.add(trace_ust_h, lttng, urcubp)
genh += trace_ust_h
endif
@@ -33,8 +30,7 @@ foreach dir : [ '.' ] + trace_events_subdirs
trace_dtrace = custom_target(fmt.format('trace-dtrace', 'dtrace'),
output: fmt.format('trace-dtrace', 'dtrace'),
input: trace_events_file,
- command: [ tracetool, group, '--format=d', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, group, '--format=d', '@INPUT@', '@OUTPUT@' ])
trace_dtrace_h = custom_target(fmt.format('trace-dtrace', 'h'),
output: fmt.format('trace-dtrace', 'h'),
input: trace_dtrace,
@@ -69,8 +65,7 @@ foreach d : [
gen = custom_target(d[0],
output: d[0],
input: meson.source_root() / 'trace-events',
- command: [ tracetool, '--group=root', '--format=@0@'.format(d[1]), '@INPUT@' ],
- capture: true)
+ command: [ tracetool, '--group=root', '--format=@0@'.format(d[1]), '@INPUT@', '@OUTPUT@' ])
specific_ss.add(gen)
endforeach
@@ -78,13 +73,11 @@ if 'CONFIG_TRACE_UST' in config_host
trace_ust_all_h = custom_target('trace-ust-all.h',
output: 'trace-ust-all.h',
input: trace_events_files,
- command: [ tracetool, '--group=all', '--format=ust-events-h', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, '--group=all', '--format=ust-events-h', '@INPUT@', '@OUTPUT@' ])
trace_ust_all_c = custom_target('trace-ust-all.c',
output: 'trace-ust-all.c',
input: trace_events_files,
- command: [ tracetool, '--group=all', '--format=ust-events-c', '@INPUT@' ],
- capture: true)
+ command: [ tracetool, '--group=all', '--format=ust-events-c', '@INPUT@', '@OUTPUT@' ])
trace_ss.add(trace_ust_all_h, trace_ust_all_c)
genh += trace_ust_all_h
endif