aboutsummaryrefslogtreecommitdiff
path: root/target/openrisc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/openrisc/meson.build')
-rw-r--r--target/openrisc/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/openrisc/meson.build b/target/openrisc/meson.build
new file mode 100644
index 0000000000..9774a58306
--- /dev/null
+++ b/target/openrisc/meson.build
@@ -0,0 +1,23 @@
+gen = decodetree.process('insns.decode')
+
+openrisc_ss = ss.source_set()
+openrisc_ss.add(gen)
+openrisc_ss.add(files(
+ 'cpu.c',
+ 'disas.c',
+ 'exception.c',
+ 'exception_helper.c',
+ 'fpu_helper.c',
+ 'gdbstub.c',
+ 'interrupt.c',
+ 'interrupt_helper.c',
+ 'mmu.c',
+ 'sys_helper.c',
+ 'translate.c',
+))
+
+openrisc_softmmu_ss = ss.source_set()
+openrisc_softmmu_ss.add(files('machine.c'))
+
+target_arch += {'openrisc': openrisc_ss}
+target_softmmu_arch += {'openrisc': openrisc_softmmu_ss}