aboutsummaryrefslogtreecommitdiff
path: root/target/hppa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/hppa/meson.build')
-rw-r--r--target/hppa/meson.build14
1 files changed, 9 insertions, 5 deletions
diff --git a/target/hppa/meson.build b/target/hppa/meson.build
index 8a7ff82efc..f47e54f5fa 100644
--- a/target/hppa/meson.build
+++ b/target/hppa/meson.build
@@ -4,16 +4,20 @@ hppa_ss = ss.source_set()
hppa_ss.add(gen)
hppa_ss.add(files(
'cpu.c',
+ 'fpu_helper.c',
'gdbstub.c',
'helper.c',
- 'int_helper.c',
- 'mem_helper.c',
'op_helper.c',
'translate.c',
))
-hppa_softmmu_ss = ss.source_set()
-hppa_softmmu_ss.add(files('machine.c'))
+hppa_system_ss = ss.source_set()
+hppa_system_ss.add(files(
+ 'int_helper.c',
+ 'machine.c',
+ 'mem_helper.c',
+ 'sys_helper.c',
+))
target_arch += {'hppa': hppa_ss}
-target_softmmu_arch += {'hppa': hppa_softmmu_ss}
+target_system_arch += {'hppa': hppa_system_ss}