aboutsummaryrefslogtreecommitdiff
path: root/target/hppa/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'target/hppa/meson.build')
-rw-r--r--target/hppa/meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/hppa/meson.build b/target/hppa/meson.build
new file mode 100644
index 0000000000..8a7ff82efc
--- /dev/null
+++ b/target/hppa/meson.build
@@ -0,0 +1,19 @@
+gen = decodetree.process('insns.decode')
+
+hppa_ss = ss.source_set()
+hppa_ss.add(gen)
+hppa_ss.add(files(
+ 'cpu.c',
+ 'gdbstub.c',
+ 'helper.c',
+ 'int_helper.c',
+ 'mem_helper.c',
+ 'op_helper.c',
+ 'translate.c',
+))
+
+hppa_softmmu_ss = ss.source_set()
+hppa_softmmu_ss.add(files('machine.c'))
+
+target_arch += {'hppa': hppa_ss}
+target_softmmu_arch += {'hppa': hppa_softmmu_ss}