aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build28
1 files changed, 16 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index da21812064..d6eb880b89 100644
--- a/meson.build
+++ b/meson.build
@@ -1741,22 +1741,10 @@ target_softmmu_arch = {}
# TODO: add each directory to the subdirs from its own meson.build, once
# we have those
trace_events_subdirs = [
- 'accel/kvm',
- 'accel/tcg',
'crypto',
- 'hw/core',
'qapi',
'qom',
'monitor',
- 'target/arm',
- 'target/hppa',
- 'target/i386',
- 'target/i386/kvm',
- 'target/mips',
- 'target/ppc',
- 'target/riscv',
- 'target/s390x',
- 'target/sparc',
'util',
]
if have_user
@@ -1773,6 +1761,7 @@ if have_block
endif
if have_system
trace_events_subdirs += [
+ 'accel/kvm',
'audio',
'backends',
'backends/tpm',
@@ -1830,6 +1819,21 @@ if have_system
'ui',
]
endif
+if have_system or have_user
+ trace_events_subdirs += [
+ 'accel/tcg',
+ 'hw/core',
+ 'target/arm',
+ 'target/hppa',
+ 'target/i386',
+ 'target/i386/kvm',
+ 'target/mips',
+ 'target/ppc',
+ 'target/riscv',
+ 'target/s390x',
+ 'target/sparc',
+ ]
+endif
vhost_user = not_found
if 'CONFIG_VHOST_USER' in config_host