aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 8 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 808f50b07e..df5bf728b5 100644
--- a/meson.build
+++ b/meson.build
@@ -1062,12 +1062,19 @@ if 'CONFIG_GUEST_AGENT' in config_host
subdir('qga')
endif
+if 'CONFIG_XKBCOMMON' in config_host
+ # used for the update-keymaps target, so include rules even if !have_tools
+ qemu_keymap = executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c') + genh,
+ dependencies: [qemuutil, xkbcommon], install: have_tools)
+endif
+
+qemu_block_tools = []
if have_tools
qemu_img = executable('qemu-img', [files('qemu-img.c'), hxdep],
dependencies: [authz, block, crypto, io, qom, qemuutil], install: true)
qemu_io = executable('qemu-io', files('qemu-io.c'),
dependencies: [block, qemuutil], install: true)
- qemu_block_tools = [qemu_img, qemu_io]
+ qemu_block_tools += [qemu_img, qemu_io]
if targetos == 'linux' or targetos == 'sunos' or targetos.endswith('bsd')
qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
dependencies: [block, qemuutil], install: true)
@@ -1078,11 +1085,6 @@ if have_tools
subdir('contrib/rdmacm-mux')
subdir('contrib/elf2dmp')
- if 'CONFIG_XKBCOMMON' in config_host
- executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c'),
- dependencies: [qemuutil, xkbcommon], install: true)
- endif
-
executable('qemu-edid', files('qemu-edid.c', 'hw/display/edid-generate.c'),
dependencies: qemuutil,
install: true)