aboutsummaryrefslogtreecommitdiff
path: root/target/i386/meson.build
diff options
context:
space:
mode:
authorClaudio Fontana <cfontana@suse.de>2020-07-07 11:39:12 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-10-05 16:41:22 +0200
commit8ef39ecfa69f758680280577077e25f4b5be9844 (patch)
tree78fc2d48f3ae4401cb02969f34243b3f3f4ff2f7 /target/i386/meson.build
parente92558e4bf8059ce4f0b310afe218802b72766bc (diff)
cpus: extract out whpx-specific code to target/i386/
register a "CpusAccel" interface for WHPX as well. Signed-off-by: Claudio Fontana <cfontana@suse.de> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'target/i386/meson.build')
-rw-r--r--target/i386/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/i386/meson.build b/target/i386/meson.build
index 1db619841c..a1a02f3e99 100644
--- a/target/i386/meson.build
+++ b/target/i386/meson.build
@@ -30,7 +30,10 @@ i386_softmmu_ss.add(files(
))
i386_softmmu_ss.add(when: 'CONFIG_HYPERV', if_true: files('hyperv.c'), if_false: files('hyperv-stub.c'))
i386_softmmu_ss.add(when: 'CONFIG_KVM', if_true: files('kvm.c'))
-i386_softmmu_ss.add(when: 'CONFIG_WHPX', if_true: files('whpx-all.c'))
+i386_softmmu_ss.add(when: 'CONFIG_WHPX', if_true: files(
+ 'whpx-all.c',
+ 'whpx-cpus.c',
+))
i386_softmmu_ss.add(when: 'CONFIG_HAX', if_true: files(
'hax-all.c',
'hax-mem.c',