aboutsummaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2019-07-15 13:06:20 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:12 -0400
commit328ec32d7d5b3c2aa2ecfe974e01bcbe3c5a46ac (patch)
tree204e29197a0011a6c778b81daea1d1f05bda0f24 /qga/meson.build
parent7272fc72682c2573c67136e2c175d33d00d8905b (diff)
meson: add msi generation
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 9ddb260cff..33f6db2865 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -48,5 +48,30 @@ qga = executable('qemu-ga', qga_ss.sources(),
if targetos == 'windows'
if 'CONFIG_QGA_VSS' in config_host
subdir('vss-win32')
+ else
+ gen_tlb = []
+ endif
+
+ wixl = find_program('wixl', required: false)
+ if wixl.found()
+ deps = [gen_tlb, qga]
+ if 'CONFIG_QGA_VSS' in config_host and 'QEMU_GA_MSI_WITH_VSS' in config_host
+ deps += qga_vss
+ endif
+ qga_msi = custom_target('QGA MSI',
+ input: files('installer/qemu-ga.wxs'),
+ output: 'qemu-ga-@0@.msi'.format(config_host['ARCH']),
+ depends: deps,
+ command: [
+ 'QEMU_GA_VERSION=' + config_host['QEMU_GA_VERSION'],
+ 'QEMU_GA_MANUFACTURER=' + config_host['QEMU_GA_MANUFACTURER'],
+ 'QEMU_GA_DISTRO=' + config_host['QEMU_GA_DISTRO'],
+ 'BUILD_DIR=' + meson.build_root(),
+ wixl, '-o', '@OUTPUT0@', '@INPUT0@',
+ config_host['QEMU_GA_MSI_ARCH'].split(),
+ config_host['QEMU_GA_MSI_WITH_VSS'].split(),
+ config_host['QEMU_GA_MSI_MINGW_DLL_PATH'].split(),
+ ])
+ alias_target('msi', qga_msi)
endif
endif