aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@redhat.com>2021-01-21 10:56:15 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2021-01-23 15:55:06 -0500
commitaa58028afb643ef3dc4a8b7ed33929f45ba043a6 (patch)
treec44707de1a2461a9dc8de181e57bee5356975ee6 /meson.build
parent813803aadf13fc7adf1bda414199b42829a1f7eb (diff)
meson: Display crypto-related information altogether
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210121095616.1471869-8-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build32
1 files changed, 18 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index d0e1156d7b..3828f327f0 100644
--- a/meson.build
+++ b/meson.build
@@ -2470,18 +2470,8 @@ if have_block
endif
summary(summary_info, bool_yn: true, section: 'Block layer support')
+# Crypto
summary_info = {}
-if targetos == 'darwin'
- summary_info += {'Cocoa support': cocoa.found()}
-endif
-# TODO: add back version
-summary_info += {'SDL support': sdl.found()}
-summary_info += {'SDL image support': sdl_image.found()}
-# TODO: add back version
-summary_info += {'GTK support': gtk.found()}
-summary_info += {'pixman': pixman.found()}
-# TODO: add back version
-summary_info += {'VTE support': config_host.has_key('CONFIG_VTE')}
summary_info += {'TLS priority': config_host['CONFIG_TLS_PRIORITY']}
summary_info += {'GNUTLS support': config_host.has_key('CONFIG_GNUTLS')}
# TODO: add back version
@@ -2495,6 +2485,23 @@ summary_info += {'nettle': config_host.has_key('CONFIG_NETTLE')}
if config_host.has_key('CONFIG_NETTLE')
summary_info += {' XTS': not config_host.has_key('CONFIG_QEMU_PRIVATE_XTS')}
endif
+summary_info += {'crypto afalg': config_host.has_key('CONFIG_AF_ALG')}
+summary_info += {'rng-none': config_host.has_key('CONFIG_RNG_NONE')}
+summary_info += {'Linux keyring': config_host.has_key('CONFIG_SECRET_KEYRING')}
+summary(summary_info, bool_yn: true, section: 'Crypto')
+
+summary_info = {}
+if targetos == 'darwin'
+ summary_info += {'Cocoa support': cocoa.found()}
+endif
+# TODO: add back version
+summary_info += {'SDL support': sdl.found()}
+summary_info += {'SDL image support': sdl_image.found()}
+# TODO: add back version
+summary_info += {'GTK support': gtk.found()}
+summary_info += {'pixman': pixman.found()}
+# TODO: add back version
+summary_info += {'VTE support': config_host.has_key('CONFIG_VTE')}
# TODO: add back version
summary_info += {'slirp support': slirp_opt == 'disabled' ? false : slirp_opt}
summary_info += {'libtasn1': config_host.has_key('CONFIG_TASN1')}
@@ -2540,7 +2547,6 @@ if targetos == 'windows'
endif
endif
summary_info += {'seccomp support': seccomp.found()}
-summary_info += {'crypto afalg': config_host.has_key('CONFIG_AF_ALG')}
summary_info += {'GlusterFS support': glusterfs.found()}
summary_info += {'TPM support': config_host.has_key('CONFIG_TPM')}
summary_info += {'libssh support': config_host.has_key('CONFIG_LIBSSH')}
@@ -2555,8 +2561,6 @@ summary_info += {'capstone': capstone_opt == 'disabled' ? false : capst
summary_info += {'libpmem support': config_host.has_key('CONFIG_LIBPMEM')}
summary_info += {'libdaxctl support': config_host.has_key('CONFIG_LIBDAXCTL')}
summary_info += {'libudev': libudev.found()}
-summary_info += {'rng-none': config_host.has_key('CONFIG_RNG_NONE')}
-summary_info += {'Linux keyring': config_host.has_key('CONFIG_SECRET_KEYRING')}
summary_info += {'FUSE lseek': fuse_lseek.found()}
summary(summary_info, bool_yn: true)