aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@redhat.com>2021-01-14 18:45:09 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2021-01-23 15:55:07 -0500
commit45b545dd190422570f92ecdb50f844e59732a955 (patch)
tree517d73b62b5f75cc9048c7dfa412acaa92320305 /meson.build
parenteae9a1d18beb2bfe42fc48330a009339dc7e8eee (diff)
meson.build: Detect bzip2 program
The --enable-bzip2/--disable-bzip2 configure arguments are somehow misleading, they check for the bzip2 library, not the bzip2 program. We need the bzip2 program to install the EDK2 firmware blobs (see commit 623ef637a2e "configure: Check bzip2 is available"). Check if the bzip2 program in the global meson.build to avoid the configuration to succeed, but a later when trying to install the firmware blobs: ../pc-bios/meson.build:5:2: ERROR: Program 'bzip2' not found Reported-by: John Snow <jsnow@redhat.com> Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Fixes: c8d5450bba3 ("configure: move install_blobs from configure to meson") Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20210114174509.2944817-3-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 94bbb4c757..35a9eddf5c 100644
--- a/meson.build
+++ b/meson.build
@@ -96,6 +96,8 @@ if get_option('install_blobs')
endforeach
endif
+bzip2 = find_program('bzip2', required: install_edk2_blobs)
+
##################
# Compiler flags #
##################