aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRoman Bolshakov <r.bolshakov@yadro.com>2021-01-02 15:52:13 +0300
committerPaolo Bonzini <pbonzini@redhat.com>2021-01-12 12:38:03 +0100
commit3eacf70bb5a83e4775ad8003cbca63a40f70c8c2 (patch)
tree1c2ea1a0fba521aa57e05054e24346777ca3d18b /meson.build
parentd533d6359b8015e2207bb7ca86330da2ef9c3ef8 (diff)
meson: Propagate gnutls dependency
crypto/tlscreds.h includes GnuTLS headers if CONFIG_GNUTLS is set, but GNUTLS_CFLAGS, that describe include path, are not propagated transitively to all users of crypto and build fails if GnuTLS headers reside in non-standard directory (which is a case for homebrew on Apple Silicon). Signed-off-by: Roman Bolshakov <r.bolshakov@yadro.com> Message-Id: <20210102125213.41279-1-r.bolshakov@yadro.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index bd4ff3118b..5e95dd6c93 100644
--- a/meson.build
+++ b/meson.build
@@ -1814,7 +1814,7 @@ blockdev_ss.add(files(
'blockdev-nbd.c',
'iothread.c',
'job-qmp.c',
-))
+), gnutls)
# os-posix.c contains POSIX-specific functions used by qemu-storage-daemon,
# os-win32.c does not
@@ -1970,6 +1970,7 @@ qmp = declare_dependency(link_whole: [libqmp])
libchardev = static_library('chardev', chardev_ss.sources() + genh,
name_suffix: 'fa',
+ dependencies: [gnutls],
build_by_default: false)
chardev = declare_dependency(link_whole: libchardev)
@@ -2188,7 +2189,7 @@ if have_tools
qemu_io = executable('qemu-io', files('qemu-io.c'),
dependencies: [block, qemuutil], install: true)
qemu_nbd = executable('qemu-nbd', files('qemu-nbd.c'),
- dependencies: [blockdev, qemuutil], install: true)
+ dependencies: [blockdev, qemuutil, gnutls], install: true)
subdir('storage-daemon')
subdir('contrib/rdmacm-mux')