aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Tokarev <mjt@tls.msk.ru>2015-06-17 21:02:03 +0300
committerMichael Tokarev <mjt@tls.msk.ru>2015-06-23 19:57:28 +0300
commit1e4db0595777b9b9a5a6a9f49ac3d187dda341f9 (patch)
tree9d84edbfe57d58010d56d2f66cca54a9e7164de7
parent417349e6e95d9aa4e0fbc01434de30e8d405ab56 (diff)
downloadqemu-arm-1e4db0595777b9b9a5a6a9f49ac3d187dda341f9.tar.gz
libcacard: pkgconfig: tidy dependent libs
libcacard.pc file lists only one package in Requires field, which is nss, while glib-2.0 is also a requiriment. Furthermore, for libraries used internally by the library (this is the way nss and glib are used by libcacard), Requires.private shold be used instead of Requires. Fix both issues. This does not affect linking of qemu because it links with objects from libcacard directly. Signed-off-by: Michael Tokarev <mjt@tls.msk.ru>
-rw-r--r--libcacard/libcacard.pc.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/libcacard/libcacard.pc.in b/libcacard/libcacard.pc.in
index b6859b0c1f..4b60023ce9 100644
--- a/libcacard/libcacard.pc.in
+++ b/libcacard/libcacard.pc.in
@@ -7,7 +7,7 @@ Name: cacard
Description: CA Card library
Version: @VERSION@
-Requires: nss
+Requires.private: nss glib-2.0
Libs: -L${libdir} -lcacard
Libs.private:
Cflags: -I${includedir}