aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-02-26 12:30:23 +0100
committerPeter Maydell <peter.maydell@linaro.org>2020-02-27 13:17:45 +0000
commit4abd08b93abb5f082aa9e21bc2330a6bc13895a0 (patch)
treedfd87b7abfbc0c5bfde2f63ed4ff2d687f41dd3f
parent38729d06fa8564a04dff8780eba29b1b963dcd00 (diff)
downloadqemu-arm-4abd08b93abb5f082aa9e21bc2330a6bc13895a0.tar.gz
qemu-doc: move system requirements chapter inside PC section
The system requirements documented in this chapter are limited to x86 KVM targets. Clean them up and move them to the target section. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com> Message-id: 20200226113034.6741-8-pbonzini@redhat.com Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
-rw-r--r--qemu-doc.texi22
1 files changed, 8 insertions, 14 deletions
diff --git a/qemu-doc.texi b/qemu-doc.texi
index 88e84300e9..40fab523f3 100644
--- a/qemu-doc.texi
+++ b/qemu-doc.texi
@@ -38,7 +38,6 @@
* Introduction::
* QEMU System emulator::
* QEMU System emulator targets::
-* System requirements::
* Security::
* Implementation notes::
* Deprecated features::
@@ -190,6 +189,7 @@ various targets are mentioned in the following sections.
@menu
* pcsys_devices:: Peripherals
* cpu_models_x86:: Supported CPU model configurations on x86 hosts
+* pcsys_req:: OS requirements
@end menu
@node pcsys_devices
@@ -267,6 +267,13 @@ CS4231A is the chip used in Windows Sound System and GUSMAX products
@include docs/system/cpu-models-x86.texi
@raisesections
+@node pcsys_req
+@subsection OS requirements
+
+On x86_64 hosts, the default set of CPU features enabled by the KVM accelerator
+require the host to be running Linux v4.5 or newer. Red Hat Enterprise Linux
+7 is also supported, since the required functionality was backported.
+
@node PowerPC System emulator
@section PowerPC System emulator
@cindex system emulation (PowerPC)
@@ -1038,19 +1045,6 @@ so should only be used with trusted guest OS.
@c man end
-@node System requirements
-@chapter System requirements
-
-@section KVM kernel module
-
-On x86_64 hosts, the default set of CPU features enabled by the KVM accelerator
-require the host to be running Linux v4.5 or newer.
-
-The OpteronG[345] CPU models require KVM support for RDTSCP, which was
-added with Linux 4.5 which is supported by the major distros. And even
-if RHEL7 has kernel 3.10, KVM there has the required functionality there
-to make it close to a 4.5 or newer kernel.
-
@include docs/security.texi
@include qemu-tech.texi