aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Maydell <peter.maydell@linaro.org>2017-04-03 13:48:18 +0100
committerPeter Maydell <peter.maydell@linaro.org>2017-04-03 13:48:18 +0100
commita3f65e213a746e82015fa049dbbe47678ebf5a0c (patch)
tree45cc570ab1035a3c88085fd780d61f990446a29d
parent6499fd151daa88a136939775dd6002235cafb193 (diff)
downloadqemu-arm-a3f65e213a746e82015fa049dbbe47678ebf5a0c.tar.gz
configure: on Windows minimum glib version must be 2.30
In the 2.7 release we stated in the ChangeLog that the minimum glib version for Windows hosts was 2.30, but we didn't update configure to enforce this because we were very close to the release at the point where we noticed the issue, and it only affected building the test suite. We then forgot that we needed to do it. Fix the omission. (The reason for the 2.30 requirement is use of g_dir_make_tmp() -- our fallback implementation uses mkdtemp(), which isn't available on Windows.) Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
-rwxr-xr-xconfigure6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure b/configure
index 4b3b5cd6bc..be4d326ae0 100755
--- a/configure
+++ b/configure
@@ -3073,7 +3073,11 @@ fi
##########################################
# glib support probe
-glib_req_ver=2.22
+if test "$mingw32" = yes; then
+ glib_req_ver=2.30
+else
+ glib_req_ver=2.22
+fi
glib_modules=gthread-2.0
if test "$modules" = yes; then
glib_modules="$glib_modules gmodule-2.0"