aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 2e3748a8..5e5d6979 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -15,7 +15,8 @@ S = "${WORKDIR}/git"
inherit update-rc.d
EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
- 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
+ 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}' \
+ 'CXXFLAGS=${CXXFLAGS} ${TARGET_CC_ARCH} -fno-rtti'"
do_compile() {
# The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.