aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-kernel')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index cf77d2df..2e3748a8 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -18,6 +18,8 @@ EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"'
'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
do_compile() {
+ # The regular makefile tries to be 'smart' by hardcoding ABI assumptions, let's use the clean makefile for everything.
+ cp ${S}/daemon/Makefile_aarch64 ${S}/daemon/Makefile
oe_runmake -C daemon
}