aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-kernel/gator
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-kernel/gator')
-rw-r--r--meta-linaro/recipes-kernel/gator/gator_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-linaro/recipes-kernel/gator/gator_git.bb b/meta-linaro/recipes-kernel/gator/gator_git.bb
index 9982b2bc..748a81c7 100644
--- a/meta-linaro/recipes-kernel/gator/gator_git.bb
+++ b/meta-linaro/recipes-kernel/gator/gator_git.bb
@@ -12,10 +12,11 @@ S = "${WORKDIR}/git"
inherit update-rc.d
+EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} ${TARGET_CC_ARCH} -DETCDIR=\"${sysconfdir}\"' \
+ 'LDFLAGS=${LDFLAGS} ${TARGET_CC_ARCH}' 'CROSS_COMPILE=${TARGET_PREFIX}'"
+
do_compile() {
- cd daemon
- # aarch64 makefile will work just fine for any arch
- make -f Makefile_aarch64 CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}
+ oe_runmake -C daemon
}
do_install() {