aboutsummaryrefslogtreecommitdiff
path: root/meta-linaro/recipes-extra
diff options
context:
space:
mode:
Diffstat (limited to 'meta-linaro/recipes-extra')
-rw-r--r--meta-linaro/recipes-extra/usecpu/usecpu_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/usecpu/usecpu_git.bb b/meta-linaro/recipes-extra/usecpu/usecpu_git.bb
new file mode 100644
index 00000000..0d4dc991
--- /dev/null
+++ b/meta-linaro/recipes-extra/usecpu/usecpu_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Uses the CPU"
+DESCRIPTION = "This program uses the CPU on a System"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;endline=39;md5=c16edc6b3353707bb4789198c72f7e48"
+SRCREV = "e246c70aa6cac5df0e593ef3416380ff75a70dc0"
+PV = "0.1+git${SRCPV}"
+
+SRC_URI = "git://git.linaro.org/people/anders.roxell/usecpu.git"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ oe_runmake use_cpu
+}
+
+do_install() {
+ install -D -p -m0755 use_cpu ${D}${bindir}/use_cpu
+}